Back to overview
Degraded
Certificate Issue – MobiControl (Customer Server 2)
May 26, 2026 at 6:38am UTC
Affected services
MobiControl (Customer server 2)
Resolved
May 26, 2026 at 6:59am UTC
The issue related to the certificate on MobiControl (Customer Server 2) has now been resolved. Services are operating normally again.
We will continue to monitor the environment to ensure stability.
Thank you for your patience.
Affected services
Created
May 26, 2026 at 6:38am UTC
We are currently experiencing an issue related to a certificate on MobiControl (Customer Server 2). This may impact connectivity and device management functionality for affected users.
Our team is actively investigating the issue and working on a resolution.
We will provide an update as soon as more information is available.
Affected services