Back to overview
Degraded
Customer server 2 login issue
Mar 6, 2026 at 9:28am UTC
Affected services
MobiControl (Customer server 2)
Resolved
Mar 6, 2026 at 10:25am UTC
The issue has been resolved. Thanks for bearing with us.
Affected services
Created
Mar 6, 2026 at 9:28am UTC
We’re expierincing issues with logging in to MobiControl (Customer server 2). We’re working to fix the problem as quickly as we can. We’ll share another update shortly.
Affected services