Back to overview
Downtime
MobiControl (Customer server 2) unavaliable
Feb 12 at 06:08pm CET
Affected services
MobiControl (Customer server 2)
Resolved
Feb 12 at 06:27pm CET
We’re back! MobiControl (Customer server 2) is up and running again. Thanks for bearing with us.
Affected services
Created
Feb 12 at 06:08pm CET
We’re investigating an issue with MobiControl (Customer server 2) that is impacting all users. We’re working to fix the problem as quickly as we can.
Affected services